kiyoka.2011_09_30 RSSPLAIN

Related pages: !kiyoka.blog.list kiyoka.2011_09_29 !kiyoka.blog.2011_09
5555445555555555555555555555555555555555555555555555555555555555555
5

[Ruby] Rubygems.orgから取得したgemでエラーが出るのはなぜか(追記)

5

 

5

昨日のエントリ「kiyoka.2011_09_29[Ruby] Rubygems.orgから取得したgemでエラーが出るのはなぜか」の続き。

5

 

4

実際に作ったGemパッケージの中のmetafileの内容を調べたのを貼りつけておく。

4

昨日のエントリに入れると、記事として長すぎるのでやめたもの。

5

 

5

Ruby 1.9.1-p429 + Syck環境 + Rubygems 1.7.2で作った

5

sekka 0.9.2の配布済みのRubyGems。

5

[gemspec]

5
  gemspec.add_dependency( "nendo", "= 0.5.3" )
5

 

5

[gem内部のmetadata]

5
rubygems_version: 1.7.2
5
- !ruby/object:Gem::Dependency 
5
  name: nendo
5
  requirement: &id015 !ruby/object:Gem::Requirement 
5
    none: false
5
    requirements: 
5
    - - "="
5
      - !ruby/object:Gem::Version 
5
        hash: 13
5
        segments: 
5
        - 0
5
        - 5
5
        - 3
5
        version: 0.5.3
5
  type: :runtime
5
  prerelease: false
5
  version_requirements: *id015
5

 

5

Ruby 1.9.2-p280 + Psych + rubygems 1.8.10で作った

5

[gemspec]

5
  gemspec.add_dependency( "nendo", "= 0.5.3" )
5

 

5

[gem内部のmetadata]

5
- !ruby/object:Gem::Dependency
5
  name: nendo
5
  requirement: &72178800 !ruby/object:Gem::Requirement
5
    none: false
5
    requirements:
5
    - - =
5
      - !ruby/object:Gem::Version
5
        version: 0.5.3
5
  type: :runtime
5
  prerelease: false
5
  version_requirements: *72178800
5

 

5

Ruby 1.9.2-p280 + Psych + rubygems 1.8.10で作った

5

[gemspec]

5
  gemspec.add_dependency( "nendo", ">= 0.5.3" )
5

 

5

[gem内部のmetadata]

5
- !ruby/object:Gem::Dependency
5
  name: nendo
5
  requirement: &72174990 !ruby/object:Gem::Requirement
5
    none: false
5
    requirements:
5
    - - ! '>='
5
      - !ruby/object:Gem::Version
5
        version: 0.5.3
5
  type: :runtime
5
  prerelease: false
5
  version_requirements: *72174990
5

 

5

 

5

...comment disabled...